Did I find the right examples for you? yes no      Crawl my project      Python Jobs

All Samples(114)  |  Call(59)  |  Derive(0)  |  Import(55)

src/b/i/biopython-1.63/Bio/Phylo/_utils.py   biopython(Download)
        import networkx
    except ImportError:
        from Bio import MissingPythonDependencyError
        raise MissingPythonDependencyError(
                "Install NetworkX if you want to use to_networkx.")
        import networkx
    except ImportError:
        from Bio import MissingPythonDependencyError
        raise MissingPythonDependencyError(
                "Install NetworkX if you want to use to_networkx.")
    except ImportError:
        raise MissingPythonDependencyError(
                "Install PyGraphviz or pydot if you want to use draw_graphviz.")
 
    def get_label_mapping(G, selection):

src/b/i/biopython-HEAD/Bio/Phylo/_utils.py   biopython(Download)
        import networkx
    except ImportError:
        from Bio import MissingPythonDependencyError
        raise MissingPythonDependencyError(
                "Install NetworkX if you want to use to_networkx.")
        import networkx
    except ImportError:
        from Bio import MissingPythonDependencyError
        raise MissingPythonDependencyError(
                "Install NetworkX if you want to use to_networkx.")
    except ImportError:
        raise MissingPythonDependencyError(
                "Install PyGraphviz or pydot if you want to use draw_graphviz.")
 
    def get_label_mapping(G, selection):

src/b/i/biopython-1.63/Bio/Graphics/__init__.py   biopython(Download)
    del r
except ImportError:
    from Bio import MissingPythonDependencyError
    raise MissingPythonDependencyError(
        "Please install ReportLab if you want "
        #i.e. We wanted renderPM but it isn't installed
        #See the import at the top of the function.
        from Bio import MissingPythonDependencyError
        raise MissingPythonDependencyError(
            "Please install ReportLab's renderPM module")

src/b/i/biopython-HEAD/Bio/Graphics/__init__.py   biopython(Download)
    del r
except ImportError:
    from Bio import MissingPythonDependencyError
    raise MissingPythonDependencyError(
        "Please install ReportLab if you want "
        #i.e. We wanted renderPM but it isn't installed
        #See the import at the top of the function.
        from Bio import MissingPythonDependencyError
        raise MissingPythonDependencyError(
            "Please install ReportLab's renderPM module")

src/b/i/biopython-1.63/Bio/DocSQL.py   biopython(Download)
import sys
 
from Bio import MissingPythonDependencyError
 
try:
    import MySQLdb
except:
    raise MissingPythonDependencyError("Install MySQLdb if you want to use "

src/b/i/biopython-1.63/Bio/motifs/jaspar/db.py   biopython(Download)
from __future__ import print_function
 
from Bio import MissingPythonDependencyError
 
try:
    import MySQLdb as mdb
except:
    raise MissingPythonDependencyError("Install MySQLdb if you want to use "

src/b/i/biopython-HEAD/Bio/motifs/jaspar/db.py   biopython(Download)
from __future__ import print_function
 
from Bio import MissingPythonDependencyError
 
try:
    import MySQLdb as mdb
except:
    raise MissingPythonDependencyError("Install MySQLdb if you want to use "

src/b/i/biopython-1.63/Bio/PDB/PDBParser.py   biopython(Download)
    import numpy
except:
    from Bio import MissingPythonDependencyError
    raise MissingPythonDependencyError(
        "Install NumPy if you want to use the PDB parser.")

src/b/i/biopython-HEAD/Bio/PDB/PDBParser.py   biopython(Download)
    import numpy
except:
    from Bio import MissingPythonDependencyError
    raise MissingPythonDependencyError(
        "Install NumPy if you want to use the PDB parser.")

src/b/i/biopython-1.63/Bio/File.py   biopython(Download)
        if not _sqlite:
            # Hack for Jython (of if Python is compiled without it)
            from Bio import MissingPythonDependencyError
            raise MissingPythonDependencyError("Requires sqlite3, which is "
                                               "included Python 2.5+")

  1 | 2 | 3 | 4 | 5  Next