Did I find the right examples for you? yes no      Crawl my project      Python Jobs

All Samples(23)  |  Call(17)  |  Derive(0)  |  Import(6)

src/f/a/fabgis-0.17.1/fabgis/postgres.py   fabgis(Download)
from fabric.colors import red, green, blue
from fabric.api import run, cd, env, task, sudo, get, put, fastprint
from .common import setup_env, show_environment, add_ubuntugis_ppa
from .utilities import replace_tokens
 
        setup_postgis_latest()
    else:
        add_ubuntugis_ppa()
        fabtools.require.deb.package('build-essential')
        fabtools.require.deb.package('postgresql-9.1-postgis-2.0')
    pg_file = '/usr/share/postgresql/9.3/contrib/postgis-2/postgis.sql'
    if not fabtools.files.is_file(pg_file):
        add_ubuntugis_ppa()
        fabtools.require.deb.package('postgresql-server-dev-9.3')
        fabtools.require.deb.package('build-essential')
    pg_file = '/usr/share/postgresql/9.1/contrib/postgis-1.5/postgis.sql'
    if not fabtools.files.is_file(pg_file):
        add_ubuntugis_ppa()
        fabtools.require.deb.package('postgresql-server-dev-all')
        fabtools.require.deb.package('build-essential')
    See: http://wiki.openstreetmap.org/wiki/Osm2pgsql#From_source
    """
    add_ubuntugis_ppa()
    fabtools.require.deb.packages([
        'build-essential',

src/f/a/fabgis-HEAD/fabgis/postgres.py   fabgis(Download)
from fabric.colors import red, green, blue
from fabric.api import run, cd, env, task, sudo, get, put, fastprint
from .common import setup_env, show_environment, add_ubuntugis_ppa
from .utilities import replace_tokens
 
        setup_postgis_latest()
    else:
        add_ubuntugis_ppa()
        fabtools.require.deb.package('build-essential')
        fabtools.require.deb.package('postgresql-9.1-postgis-2.0')
    pg_file = '/usr/share/postgresql/9.3/contrib/postgis-2/postgis.sql'
    if not fabtools.files.is_file(pg_file):
        add_ubuntugis_ppa()
        fabtools.require.deb.package('postgresql-server-dev-9.3')
        fabtools.require.deb.package('build-essential')
    pg_file = '/usr/share/postgresql/9.1/contrib/postgis-1.5/postgis.sql'
    if not fabtools.files.is_file(pg_file):
        add_ubuntugis_ppa()
        fabtools.require.deb.package('postgresql-server-dev-all')
        fabtools.require.deb.package('build-essential')
    See: http://wiki.openstreetmap.org/wiki/Osm2pgsql#From_source
    """
    add_ubuntugis_ppa()
    fabtools.require.deb.packages([
        'build-essential',

src/f/a/fabgis-0.17.1/fabgis/gdal.py   fabgis(Download)
from fabric.api import fastprint, run, cd, env, task, sudo, settings
 
from .common import add_ubuntugis_ppa, setup_env
from .system import setup_ccache
from .proj4 import build_proj4
    """
    setup_env()
    add_ubuntugis_ppa()
    fabtools.require.deb.package('subversion')
    fabtools.require.deb.package('build-essential')

src/f/a/fabgis-HEAD/fabgis/qgis.py   fabgis(Download)
from fabric.contrib.files import upload_template
import fabtools
from .common import add_ubuntugis_ppa
from .common import setup_env
from .git import update_git_checkout
    """
    setup_env()
    add_ubuntugis_ppa()
    setup_ccache()
    sudo('apt-get build-dep -y qgis')
    setup_env()
    setup_ccache()
    add_ubuntugis_ppa()
    sudo('apt-get build-dep -y qgis')
 
    setup_env()
    setup_ccache()
    add_ubuntugis_ppa()
    sudo('apt-get build-dep -y qgis')
 
    setup_env()
    setup_ccache()
    add_ubuntugis_ppa()
    sudo('apt-get build-dep -y qgis')
 

src/f/a/fabgis-0.17.1/fabgis/qgis.py   fabgis(Download)
from fabric.contrib.files import upload_template
import fabtools
from .common import add_ubuntugis_ppa
from .common import setup_env
from .git import update_git_checkout
    """
    setup_env()
    add_ubuntugis_ppa()
    setup_ccache()
    sudo('apt-get build-dep -y qgis')
    setup_env()
    setup_ccache()
    add_ubuntugis_ppa()
    sudo('apt-get build-dep -y qgis')
 
    setup_env()
    setup_ccache()
    add_ubuntugis_ppa()
    sudo('apt-get build-dep -y qgis')
 

src/f/a/fabgis-HEAD/fabgis/gdal.py   fabgis(Download)
from fabric.api import fastprint, run, cd, env, task, sudo, settings
 
from .common import add_ubuntugis_ppa, setup_env
from .system import setup_ccache, get_processor_count
from .proj4 import build_proj4
    """
    setup_env()
    add_ubuntugis_ppa()
    fabtools.require.deb.package('subversion')
    fabtools.require.deb.package('build-essential')