Did I find the right examples for you? yes no

All Samples(4)  |  Call(2)  |  Derive(0)  |  Import(2)
Check python version eq 2.6 or 2.7

        def verify_python_version():
    """
    Check python version eq 2.6 or 2.7
    """
    major, minor, micro, releaselevel, serial = sys.version_info
    if major == 2:
        if minor not in (6, 7):
            msg = 'Error: Python 2.%s found but Python 2.6 or 2.7 required.'
            print(msg % minor)
    elif major > 2:
        msg = 'It seems that you are running Python 3k, please let us know if' \
              ' w3af works as expected at w3af-develop@lists.sourceforge.net !'
        print(msg)
        sys.exit(1)
        


src/w/3/w3af-HEAD/w3af/core/controllers/dependency_check/dependency_check.py   w3af(Download)
 
from .lazy_load import lazy_load
from .utils import verify_python_version
from .helper_script import (generate_helper_script,
                            generate_pip_install_non_git,
    :return: True if the process should exit
    """
    verify_python_version()
 
    disable_warnings()

src/t/o/Tortazo-HEAD/w3af/core/controllers/dependency_check/dependency_check.py   Tortazo(Download)
 
from .lazy_load import lazy_load
from .utils import verify_python_version
from .helper_script import (generate_helper_script,
                            generate_pip_install_non_git,
    :return: True if the process should exit
    """
    verify_python_version()
 
    disable_warnings()